Settings as a URL / Cookieless Mojeek

I’ve included the r_foc=1 parameter in my URL. Searching will drop the parameter from the URL. But if I add it to the results page, navigating between search result pages does not cause the issue.

It’s a good point actually; the r_foc and s_foc being set within the Focus Dashboard means they’re not bundled up in this. I will look into it. It’s a complex one as Focus is separated out so it has its own settings etc.

Please include si_foc= in your research.

The autocomp=0 parameter is not working.

Thanks @mike. It’s OK in Firefox so probably a Chromium thing; I was able to reproduce on Vivaldi.

1 Like

So it does looks like this is, as suspected, a Chromium thing. Basically it does not respect the html tag ‘autocomplete=“off”’, and it never did.

There are two issues submitted in 2016 and 2018 where the developers of Chromium think that they should not respect the tag. Discussions 587466 - chromium - An open-source project to help move the web forward. - Monorail and 914451 - chromium - An open-source project to help move the web forward. - Monorail

We are looking some more into this. This is a prime example of Google values being imposed on the world, with user control being denied.

1 Like


To that I can add auto-play on YouTube and “session” cookies lasting twenty-four hours even when the browser is closed.

I don’t understand. You need to add\edit a cookie in order for this to work?
I have tried to use a modified search URL, but it seems not all options are supported. Is that correct?

@M1Aston This thread is related to testing. The cookie formerly enabled the interface.

Now the cookieless interface shows all the time.

So, if I open a browser with no cookies, I can access this feature without adding a cookie. Here is a GIF showing how to change the number of results per page:

Screencast of setting up cookieless

The other search settings are supported and will generate similar URLs.

If you then bookmark that URL, you can retain your settings without using a cookie.

Just don’t click on the Save button in the settings and no cookie will be saved. Or, if you have the cookieless URL that you want, you can delete any Mojeek cookies and the URL will continue to function.


Hey @M1Aston, are you able to let us know which options you’re unable to use if you’re currently using the non-testing version and finding issues. Thanks

This is the bookmarked URL.
When doing a search, the arc=nl option is dropped\removed from that URL (visible in the URL bar) and is not used in the search results.

Thanks for this @M1Aston, we’re working on it.

Should be fixed now @M1Aston, please let us know if you experience any other issues.


This is a great feature and a major reason why I still use Startpage and Qwant.

However, I noticed that opening the page defined in the custom URL and then selecting Settings shows the settings at their default values. The custom settings do appear to work after doing this, though, going by the visual cue that I get a date stamp on results, which I don’t get if I search directly from the address or search bars.

If possible, it could remove potential confusion if the settings showed the customised results, rather than the default ones. I imagine that many people would see the default settings, not bother to test and just assume that their custom settings aren’t being applied.

For reference, my settings URL is Mojeek and my browser is Firefox Manjaro 1.0 version 104.0.2 (up-to-date at time of writing). The main settings I want are the date stamp, location set to “none” and Referral Data checked.

Mojeek is looking very promising, thanks for all the hard work!

1 Like

It’s very good to hear it, thanks a lot.

Basically once you’ve navigated away from the home/search page, the parameters dropping off is expected behaviour for how we’ve built it. If you were to go to your created URL but with /preferences then you should see the box filled in the way you’re expecting.

:pray: :pray: :pray:

1 Like

I’ve edited the bookmark, thanks.

1 Like


It seems to be working now, or perhaps not, but I’m not impressed with the results. Searching for “something international” sometimes hardly returns any .nl domain names.
For example “Audi”. Only 1 of the first 20 results is .nl. And that is, at 15th place… Loads of .de, .com, .uk, even .fr.
Something seems to be wrong.

While we wait for an official response,

You might try using the site:nl keyword:

If you’re willing to use cookies, you can permanently set a site: using Focus.

1 Like

Thanks for that @mike, hadn’t thought about doing things that way but it makes sense.

When it comes to arc, we’re aware that it’s not quite there, the parameter rests on us having correct data which up until now we’ve not had a great method for. This being said, it is something we’re aware of and are actively working on. We’ve actually done something very recently which should start to feed in more correct data for this (mostly) but it takes time as well to implement changes.

Just to add in more information to this answer @M1Aston, as it’s not as complete/good as it could be.

The arc parameter above all else is a hint, used either when country auto-detection is incorrect, or when you want to override it.

By default, pages we think are targeted towards a person’s detected or selected country are given a small boost; this can be turned off or modified with the rbb parameter, to illustrate this:
= A search with this boost turned off completely
= A search with this boost as it is by default
= A search with this boost as high as it can possibly go

To restrict results to a specific country and not just use a boost, reg is the correct parameter to use. This will include pages with the right country TLD, but also pages which don’t have that, but we think are targeted towards that country.

This being said, what country a page is targeted towards is not accurate and is something we’re actively trying to improve.