Feedback on Focus

Hello again Mojeek!

First bit of feedback is a straight-up bug: once I’ve made a focus, if I try to delete it, the button to cancel works, but the button to confirm does nothing. I click “OK” repeatedly until I give up and cancel. So the only way I can delete a focus seems to be to wipe my cookies?

The second is, I think the focusses would probably be a bit more useful if you could add partial URLs rather than just domains.

E.g., if I search for Test and apply the Dictionaries focus, the top result is a list of challenging words to use in tests (or something) from Merriam-Webster. The third result is the actual definition of the word “test” from Merriam-Webster.

The top result has a URL of the format… whereas the definition of Test is at

So, if the purpose of the Dictionaries focus is to return some actual definitions for your search term, I think it would be more powerful if you could add to the list of sites, rather than just It would just mean you can be more specific and selective.

Hey Jags, are you able to provide your device and browser for this? We’re unable to replicate it :pray:

Oh, unexpected - I’m on Nothing Phone using Chrome.

While we’re on possibly device- or browser-specific issues… in landscape the search bar is drawn over the logo and menu items:

1 Like

Morning @Jags,

Thanks for letting us know - I’ve reproduced this locally so will get a fix pushed up for it.

All the best!


Is the update on this bug already pushed out? I’ve noticed the same behaviour.

I’m on a dekstop running TuxedoOS. Chromium based browsers don’t seem to be able to delete a focus (I’ve tried Vivaldi and ungoogled chromium). Firefox doesn’t seem to have an issue with this.

The search bar issue was; I’ve replicated your issue on UC and Vivaldi and raised an issue for it :pray:


@Jags This has been fixed and pushed, can you test and confirm for me please?

@videonas This too has been fixed and pushed - confirmed our end but please double check yourself and let us know.


The issue is fixed for deleting a single Focus. The “Yes” button on the pop-up for “delete all” still doesn’t do anything.