Error when changing main email

When I tried to change my main email address of my account while having a security key added to my account, when i enter the link that I got to the new email I get this error.

Did the same thing happen to anyone else?

Yep the same thing has happened to me here with a hardware key enabled

You supplied invalid parameters to the request: Discourse::InvalidParameters

I’ll make a note to dig further, sorry about that @nsoolo

1 Like

So this is not a fix for the actual error but I can confirm (at least for me) that removing the hardware key, confirming the email, then adding the key back in works.

Not really a great solution but in a pinch it will at least allow you to change the account email and still use your 2FA.


Sorry I forgot about the post.

Yes the solution of disabling, and changing my email and re-enabling worked perfect.

Thank you very much for your time.

1 Like

Hello there,

Thanks for sharing these insights mate as I was facing this issue too.

1 Like